Soluție pentru eroarea 0x800F0906 la instalarea .NET Framework 3.5 (includes .NET 2.0 and 3.0)

Imediat după instalarea Windows 8.1 build 9471 am început să instalezi programele de care am nevoie zilnic. Unul dintre acestea, nu mai țin mint care, necesita .NET Framework 3.5 pentru a funcționa, dar a cărui instalare automată nu a fost posibilă, acțiunea raportând eroare 0x800F0906:

0x800F0906

Am mai avut parte de această eroare și în Windows 8, așa că știam ce aveam de făcut:
Continuarea…